Jump to content


Photo

2zzge has a misfire at idle, doesn't seem to be driving as well, occasionally backfires on engine brake


  • Please log in to reply
34 replies to this topic

#31 trd_st_162

trd_st_162

    OZCelica Junkie

  • Members
  • PipPipPip
  • 2,361 posts
  • Gender:Male
  • STATE:VIC

Posted 08 April 2016 - 11:56 AM

Injectors?

Good question. Seems so strange that the idle drops so much after the same amount of time. Would bad injectors be so consistent to cause the issue after say 10 seconds everytime I wonder.



#32 ZRB

ZRB

    OZCelica Junkie

  • Members
  • PipPipPip
  • 2,045 posts
  • Gender:Male
  • STATE:NSW

Posted 08 April 2016 - 12:56 PM

When I had the issue initially, my mechanic cleaned the injectors while they were still on the car, rather than a sonic bath. Though this didn't fix it. For me, it was the MAF and cleaning the throttle bottle helped.

 

So could be the injectors for you.



#33 trd_st_162

trd_st_162

    OZCelica Junkie

  • Members
  • PipPipPip
  • 2,361 posts
  • Gender:Male
  • STATE:VIC

Posted 09 April 2016 - 01:56 PM

Well I finally ran the codes on techstream and its worse than I thought

 

Strangely the car felt the best on the cheapest $44 maf sensor. Car felt more perky

 

Seems like the ignition coils are gone also?

 

Attached File  errors-doh.JPG   38.26KB   2 downloads



#34 ChocSoldier

ChocSoldier

    Forum Member

  • Members
  • PipPip
  • 243 posts
  • Gender:Male
  • Location:Western Sydney
  • STATE:NSW

Posted 09 April 2016 - 02:51 PM

Well I finally ran the codes on techstream and its worse than I thought

 

Strangely the car felt the best on the cheapest $44 maf sensor. Car felt more perky

 

Seems like the ignition coils are gone also?

 

attachicon.giferrors-doh.JPG

Maybe try clearing the codes and swapping the good coil (#2) somewhere else to see what comes up. If the bad coil shows as bad on another cylinder then I guess replace the coil packs.

Before that though, there should be a resistance check or something like that in the service manual for the coil packs, might be worth looking into that.


2009 370Z (close enough to a 7th gen :P)

2002 ZZT231 SX

1993 ST184 WRC Trophy


#35 trd_st_162

trd_st_162

    OZCelica Junkie

  • Members
  • PipPipPip
  • 2,361 posts
  • Gender:Male
  • STATE:VIC

Posted 09 April 2016 - 03:15 PM

Thanks heaps. I am tempted to just replace them as they have done 160k.

I would love to find someone in aus that might have a spare set of coils and maf sensor to try




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users