Jump to content


Photo

Would there be any issue with using an automatic front engine mount in a manual?


  • Please log in to reply
2 replies to this topic

#1 Drive

Drive

    OZCelica Newbie

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Gold Coast
  • STATE:QLD

Posted 23 June 2017 - 02:09 AM

By mistake I ordered a front engine mount which turned out to be for the automatic version. The design of the rubber is slightly different but it fits the same; would it be safe to drive with this? Would there be significant differences in performance etc?

 

I'll order the correct one soon but I am curious.


Edited by Drive, 02 July 2017 - 03:16 AM.


#2 hemimark

hemimark

    OZCelica Newbie

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:Perth Western Australia
  • Interests:American Mopar muscle cars especially 1968-1970 B bodies and 1970-1971 E bodies. Celica ST165 and Skyline R32 GT/R.
  • STATE:WA

Posted 02 July 2017 - 02:50 PM

The engine placement within the engine bay will be the same as long as the mount adaptor bracket that bolts to the transmission is the same on the auto and manual I can't see why the mount would be different.

#3 Drive

Drive

    OZCelica Newbie

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Gold Coast
  • STATE:QLD

Posted 03 July 2017 - 01:51 PM

I assumed the automatic mount is rated for less as it only has one diagonal bit of rubber verses the X design on the manual mount. Maybe it would give a little more play overall. I also assumed the auto would wear out faster.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users